CVE-2020-15125 – In auth0 (npm package) versions before 2.27.1, a DenyList of specific keys that should be …

Vuln ID: CVE-2020-15125

Published:  2020-07-29  17:15:13Z

Description: In auth0 (npm package) versions before 2.27.1, a DenyList of specific keys that should be sanitized from the request object contained in the error object is used. The key for Authorization header is not sanitized and in certain cases the Authorization header value can be logged exposing a bearer token. You are affected by this vulnerability if you are using the auth0 npm package, and you are using a Machine to Machine application authorized to use Auth0’s management API

Source: NVD.NIST.GOV