CVE-2019-11770 – In Eclipse Buildship versions prior to 3.1.1, the build files indicate that this project i …

Vuln ID: CVE-2019-11770

Published:  2019-06-14  14:29:00Z

Description: In Eclipse Buildship versions prior to 3.1.1, the build files indicate that this project is resolving dependencies over HTTP instead of HTTPS. Any of these artifacts could have been MITM to maliciously compromise them and infect the build artifacts that were produced. Additionally, if any of these JARs or other dependencies were compromised, any developers using these could continue to be infected past updating to fix this.

Source: NVD.NIST.GOV

 

Tags